Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 16, 2025 - 22:05 EDT
Scheduled
Summary: 11:11 Engineering will be updating the 11:11 Secure Cloud Backup and Secure DRaaS with Veeam services. This latest vendor update incorporates significant bug fixes and enhancements for all customers currently utilizing this service. This update also addresses the veeam CVE-2025-23120 published here: https://www.veeam.com/kb4724.
Impact: During this maintenance window, the 11:11 Secure Cloud Backup and Secure DRaaS with Veeam services will be unavailable. All backup and restoration services will be offline and unavailable for the duration of the maintenance window. Once the maintenance is concluded some customers may be unable to see active backups in the customer portal. Jobs are still running as expected but console may take up to 24 hours to update with backup information.
Customer Action: There is no action required. All services will resume as normal at the end of the maintenance window.
Posted Apr 16, 2025 - 22:02 EDT
This scheduled maintenance affected: IaaS (IaaS - Houston, TX).