Phone service disruption
Incident Report for Green Cloud Defense
Resolved
Green Cloud has monitored the phone systems overnight and we believe service has been fully restored for all customers as of 9 pm last night. Please let us know if that is not the case at 877-465-1217 option 1 option 1 or via email at phones@gogreencloud.com.

We would like to extend our deepest apologies to you for the extended impact of the phone system failure. There was a catastrophic problem on a core piece of equipment that manages the phone infrastructure that took many hours to resolve after much vendor involvement. We do not believe that this issue should recur, but teams are on high alert nonetheless.
Posted Nov 30, 2017 - 09:09 EST
Monitoring
The phone team has repaired the underlying issue. Phone service should begin returning to normal service.
Posted Nov 29, 2017 - 21:40 EST
Update
Our team of engineers are still working with the system at this time.
Posted Nov 29, 2017 - 18:52 EST
Update
Green Cloud is still experiencing an issue with the phone systems. Service was briefly restored for some users. However, the issue still persists. Our Team is working to resolve this issue.
Posted Nov 29, 2017 - 16:21 EST
Update
Our phone team has identified the issue with the phone system and is continuing to work toward a resolution at this time.
Posted Nov 29, 2017 - 14:14 EST
Identified
Our phone team has identified the issue with the phone system and is working toward a resolution at this time.
Posted Nov 29, 2017 - 13:27 EST
Investigating
Our phone team is currently looking into issues with the phone system.
Posted Nov 29, 2017 - 13:01 EST